Welcome to Gaia! ::

My character is stuck in the river in the area where the bridge is to the left of the null crystal. I went to see Buzzkill for my first time just to check him out, he took 50% of my life so I ran like hell and all of a sudden my character hit light speed and wedged himself passed, what I assume to be, an invisible wall. I've tried to WASD and click move and he doesn't budge an inch. I've also tried refreshing and that didn't help. Another guy got stuck in the same area as me deeper into the river (forgot his name but I remember it had the words "dark" and "eden" and a bunch of underscores in it, sorry guy) he had the idea of someone luring a buzzsaw to come over and kill us but no one lured, at the time of this post, he's logged out of zOMG. It's more obvious to see im glitched at night because the shade doesn't go over my character and it looks like he's still in daylight. I'm running on Windows 7, Google Chrome, and Flash Player version

Heads up thanks to anyone that can help.
I'm not stuck anymore biggrin heart I was disconnected and when i logged back in I was in Barton. Thank you for the quick fix and help heart

Quick Reply

Manage Your Items
Other Stuff
Get GCash
Get Items
More Items
Where Everyone Hangs Out
Other Community Areas
Virtual Spaces
Fun Stuff
Gaia's Games