Welcome to Gaia! ::

How to report a Bug

First thing to do when a member contacts you regarding a possible bug:

1. Check an announcement!
If user experiences a problem during some new project push, it is probably
temporary and will be resolved after push is completed.

2. Can you reproduce the problem?

To make sure the problem is real:
Clean up the cache and cookies
Log out and log back in
Is it still reproducible?
If it is reproducible, please provide the following information:

OS: Mac? Win? WinXP?
Browser: IE6? IE7? FF? Safari? Opera?
Version: FF 2.0.5? FF 3? IE7 sp 2?
Brief description of the problem
Steps to reproduce:

Examples and templates are below.

3. Before you report the bug, please check other people's reports!!!!

4. Please report 1 bug in 1 post

REPORTING A BUG

Provide detailed and useful information when reporting!
The purpose of reporting a bug is so that later on a Developer will have enough information to reproduce the problem and resolve it. Reports made that do not provide useful information and are vague with no detail will be deleted.

Be descriptive in your title
Don't just put "Bug" in your title. For example, if something like Cinemas isn't poping up, put "Gaia Cinemas isn't popping up Bug."

Quick Format for posting bug reports:

Short description of the problem:


Browser:
Operation system:


Step 1- Log onto www.gaiaonline.com

Step 2-

Step 3-

Step 4-

Step 5-

Supposed to be Result:


Actual result:



Here's an example of how to write a bug:


Computer Specs:
Windows Vista Home Edition
Internet Explorer 7.0.6000.16609
Flash 9.0.115.0

Location:
Slots (Upper right hand corner of game)

Bug:
Playing winnings button does not work when you have over 10 winnings awarded

Reproduction:
1) Go to www.gaiaonline.com/
2) Log in as a user: user name and password
3) Go to the web page www.gaiaonline.com/games
4) Click on Slots
5) Pick any available room
6) Click on the Join button
7) Click on the Play Token button
cool Click on the Spin button
9) Repeat steps 7-8 until you have at least 10 winnings awarded

*Current winnings will display the number 10, right below Tickets and Tokens on the left center side

10) Click on the Play Winnings button

Result:
The button will not work. The current winnings do not decrement (decrease). The spin button does not work since no winnings or tokens are used.

Notes:
Any useful information goes here, such as how often this occurred.

If you notice for the above bug, it is very detailed and concise. If you were to go through the reproduction steps, you should be able to reproduce the bug, or if it is uncommon, occasionally reproduce the bug. smile


How NOT to write a bug:
Example1:

Computer Specs:
Windows

Location:
Slots


Location:
I don't remember

Bug:
The slots machine didn't work.

Reproduction:
Play slots by putting in tokens.

Result:
The slots machine didn't work.

Notice how everything is vague? If you were to try to go through the steps again, you would not have a clue where to start. Try to be as detailed as you can by giving any information such as: computer information and what you were doing before, if you used any power ups, etc. This way we can narrow down the possibilities.
Amber Kittie Powell's avatar

Hilarious Genius

8,700 Points
  • Partygoer 500
  • Loiterer 100
  • Millionaire 200
Mozilla Firefox (fully updated)
Has been this way for three days now.

In the "For The Love Of Gaia" Event I have all 55 hearts collected but the Candy heats bar shows I have 29 collected. What do I do to get my reward? crying
Sweet Beautie's avatar

Magnetic Sweetheart

10,850 Points
  • Thread Flip 150
  • Protector of Cuteness 150
  • Destroyer of Cuteness 150
chirpysmom's avatar

Questionable Genius

12,500 Points
  • Megathread 100
  • Invisibility 100
  • Elocutionist 200
Computer Specs:
Windows 7 Home Premium
Google Chrome Version 24.0.1312.57 m

Location:
For the Love of Gaia event.

Bug:
Love Machine Achievement does not grant.

Reproduction:
1) Go to www.gaiaonline.com/
2) Log in as a user: user name and password
3) Click on the hamster in the header.
4) Go to the web page www.gaiaonline.com/event/fortheloveofgaia
5) Click on Visit Forums on the event landing page
6) Select any topic
7) Under any user, click on Send Valentine
cool Once you have sent 100 valentines, the Love Machine achievement should be granted

*Current valentines sent will display next to the cupid on the event landing page or on the upper right of the event page. They will also display just under the subforums list on the For the Love of Gaia forums page.


Result:
The Love Machine achievement is not granted, regardless of whether or not the user logs out and back in and/or refreshes the page. Also regardless of whether or not the user sends another valentine.
Obscurus's avatar

Enduring Phantom

14,650 Points
  • Millionaire 200
  • Forum Regular 100
  • Big Tipper 100
Myself a some other users have been granted some Heralds of Chaos achievements that we did not earn. This seems to be related to the event that is going on right now.

The day the event started I logged on and went to the event page and the Heralds of Chaos achievements related to wins all popped for me even though I don't have the required wins. I've seen other users say that the same thing happened to them in regards to visiting the event page.

I'm running Firefox on Windows XP. I have not attempted to reproduce this bug.
--Windows 7
--FF 18

I have to wait 11 minutes between each PM sent. I know this isn't right. I've talked to others and they don't seem to have this problem. I'm a mule account but I also have this problem on my main account (Tangled Puppet). I've even recently cleared my cache. I've had this problem since I came back to Gaia about a year ago. It wasn't a big deal until recently when I needed to send out multiple PMs for my shop.

Hi, Please contact customer service.

Thanks
selvinivi
Kuri Hesyolilit's avatar

Precious Shapeshifter

11,750 Points
  • Bookworm 100
  • 50 Wins 150
  • Elysium's Gatekeeper 100
Browser: I use Chrome (This effects any)
Operation system: Windows 7 (Any truly are affected)


Step 1- Log onto www.gaiaonline.com

Step 2- Switch into certain "I AM" items

Step 3- Open Towns

Step 4- Choose An Area

Step 5- MOVE

Supposed to be Result: Normal moving, normal activity as if it still had the green blob


Actual result: MASS FREEZING, Certain "I AM"s will freeze themselves and others (ranging from 1 to All) and do not unfreeze it exiting Towns 1.

Side Note: This is upsetting a lot of people. I don't care if you have to temp put the green blob back, But it would be nice to see this fixed asap before Towns 2 has to come out.
Nikiana's avatar

Sparkly Hoarder

Computer specs:
-Windows 7
-Firefox 18.0

Location:
-Forums and guilds (might be fixed in guilds now though?)

Bug:
-Some images not showing and displaying "user image" instead.

Reproduction:
-Go here: http://www.gaiaonline.com/forum/breedable-changing-pets/sc-hiring-820-vday-event-and-grams-2/t.79377659_16

Result:
-In the first post there are three images that do not show in Firefox, but yet with me sitting here at my computer, dual screen, I can have that exact same page open in IE and all the images load just fine. I've cleared cookies and cache from FF and am not the only user experiencing problems. It's always the same images that we can't see.

Notes:
-Some people say the images work fine in Chrome, but I don't have that browser, so I can't check myself. I just know that they do work in IE, but not in FF.
l 9 9 l's avatar

Kawaii Shounen

14,200 Points
  • Battle: KO 200
  • Beta Gaian 0
  • Senpai's Notice 100
All browsers, green goo dots whenever trying to equip OMG (hat). I counted 6 dots or so, grouped in 2 differentbplaces.

It's annoying how such an expensive item has such glitched display.

I tried all poses, naked, and clothed, everything. Hope the artists fix it soon.
Wicked Erection's avatar

Ruthless Sex Symbol

12,550 Points
  • The Perfect Setup 150
  • Brandisher 100
  • Peoplewatcher 100
OS: Mac osx 10.6
Browser: Mozilla 5.0
Version: FF 18.0.2
Brief description of the problem:

I can't save my avatar. emotion_donotwant

Steps to reproduce:
1. Log into Gaia
2. Click on "My Gaia" tab
3. Click on "Avatar" section
4. Make avatar
5. Click "save"

What's supposed to happen:
Obviously your avatar is supposed to save

What actually happens:
I get an error message
I cannot save my avatar.

"Save failed, please try again.

Reason: Something went wrong. We couldn't build your avatar. Please try again.

If the problem persists, click on "Get Nekkid", save your avatar, and try again."

I've tried following the prompt, and nothing works.
Dakini Jun's avatar

Gracious Wench

10,100 Points
  • Nerd 50
  • Friendly 100
  • Jolly Roger 50
Custom built PC using Windows 7.
Firefox 18.0 Browser.

Unreproducible error. At least I tried several times now and it didn't happen again.

The dancing gift trunk floats up, I click on it and it disappears.

Happened twice about 15 minutes ago. Tried to get it to appear again and it didn't.

Thought you'd like to know.
Sweet Beautie
http://www.gaiaonline.com/marketplace/itemdetail/10004759/
This item can't be sold in the inventory.
This. Also I found another item, too.

Short description of the problem: Some items with listed sellback prices are not possible to sell back from the inventory.


Browser: Firefox 17.0.1
Operation system: Windows 7


Step 1- Log onto www.gaiaonline.com

Step 2- Go to the marketplace and buy one of the following: Riot Shield, Gold Partition Top. Take note that these items both have listed sellback prices; 10,000 gold and 350 gold, respectively.

Step 3- Go to your inventory at http://www.gaiaonline.com/inventory

Step 4- Click one of the mentioned items

Supposed to be Result: You get the options to Equip, Gift, Sell or Donate the item


Actual result: You don't get the option to Sell the item, instead you are given the additional option to Trash it.
Sweet Beautie's avatar

Magnetic Sweetheart

10,850 Points
  • Thread Flip 150
  • Protector of Cuteness 150
  • Destroyer of Cuteness 150
some bee's avatar

Enduring Treasure

11,400 Points
  • Object of Affection 150
  • Partygoer 500
My issue is not with one of your flash files or my browser, so I don't believe system is required.
When you're about to post something and hit "Preview", the preview shows that many symbols are available and will work when posted, when they actually just turn into squares when posted.
Up is how it looks in Preview Mode, down is how the finished post looks.
̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶̶̶̶ ̶̶̶

It's really frustrating.
User Image - Blocked by "Display Image" Settings. Click to show.
Struggle and Strife's avatar

Dangerous Explorer

11,150 Points
  • Jolly Roger 50
  • Flatterer 200
  • Risky Lifestyle 100

Computer Specs:
Windows Vista Home Edition
Google Chrome Version 24.0.1312.57 m

Location:
Gaia header achievements page

Bug:
Millionaire achievement does not grant properly/ Possible Score Exploit

Reproduction:
1) Go to www.gaiaonline.com/
2) Log in as a user: user name and password
3) Have one million gaia gold
4) Get the "Millionaire" achievement granted popup
5) Click [from the popup] to go to the event Achievements landing page
6) Find the "Millionaire" achievement granted [and stays granted]

Result:
The Millionaire achievement says it's granted [via popup] but it is not granted. After reaching 1 million gold, I got the popup telling me I achieved/was granted my Millionaire achievement. I followed the popup to my achievements page and found it has not granted. It still shows under the Available Achievements and with zero progress.

I tested something by temp moving my gold to a friend. To see what happens if the gold drops below one million and is built back. Once that temp trade got cancelled and my gold returned to over a million again, I received the false popup notice of a Millionaire achievement grant. I should also point out that it does add 200 points to one's score each time the it shows the false grant.

That cannot be good as anyone unknowing or wishing to purchase anything [who is affected by this Achievement glitch] using their gold could be seen as exploiting a glitch. This hardly seems unfair. Am I now expected to halt purchases and selling due to this? :/

By the way, I'm not alone.


Edit: I logged into Gaia today [February 19, 2013] and received the popup once again saying I have earned the Millionaire achievement. I followed the popup and it has now granted it and place it under the Newest Achievement and Completed Achievements section. I am no longer experiencing the above glitch but the others at the thread linked above maybe.

Quick Reply

Submit
Manage Your Items
Other Stuff
Get Items
Get Gaia Cash
Where Everyone Hangs Out
Other Community Areas
Virtual Spaces
Fun Stuff
Gaia's Games