Welcome to Gaia! ::

jseverin's avatar

3,550 Points
  • Conventioneer 300
  • Beta Gaian 0
  • Beta Voter 0
How to report a Bug

First thing to do when a member contact you regarding a possible bug:

1. Check an announcement!
If user experience a problem during some new project push it is probably
temporary and will be resolved after push is completed.

2. Can you reproduce the problem?

To make sure the problem is real:
Clean up the cash and cookie
Log out and log in back
Is it still reproducible?
If it is reproducible, please provide the following information:

OS: Mac? Win? WinXP?
Browser: IE6? IE7? FF? Safari? Opera?
Version: FF 2.0.5? FF 3? IE7 sp 2?
Brief description of the problem
steps to reproduce:

Example and templates are below.

3. Before you report the bug, please check other people's reports!!!!

4. Please report 1 bug in 1 post

REPORTING A BUG

Provide detailed and useful information when reporting!
The purpose of reporting a bug is so that later on a Developer will have enough information to reproduce the problem and resolve it. Reports made that do not provide useful information and are vague with no detail will be deleted.

Be descriptive in your title
Don't just put "Bug" in your title. For example, if something like Cinemas isn't poping up, put "Gaia Cinemas isn't popping up Bug."

Quick Format for posting bug reports:

Short description of the problem:


Browser:
Operation system:


Step 1- Log onto www.gaiaonline.com

Step 2-

Step 3-

Step 4-

Step 5-

Suppose to Result:


Act result:



Here's an example of how to write a bug:


Computer Specs:
Windows Vista Home Edition
Internet Explorer 7.0.6000.16609
Flash 9.0.115.0

Location:
Slots (Upper right hand corner of game)

Bug:
Playing winnings button does not work when you have over 10 winnings awarded

Reproduction:
1) Go to www.gaiaonline.com/
2) Log in as a user: user name and password
3) Go to the web page www.gaiaonline.com/games
4) Click on Slots
5) Pick any available room
6) Click on the Join button
7) Click on the Play Token button
cool Click on the Spin button
9) Repeat steps 7-8 until you have at least 10 winnings awarded

*Current winnings will display the number 10, right below Tickets and Tokens on the left center side

10) Click on the Play Winnings button

Result:
The button will not work. The current winnings do not decrement (decrease). The spin button does not work since no winnings or tokens are used.

Notes:
Any useful information goes here, such as how often this occurred.

If you notice for the above bug, it is very detailed and concise. If you were to go through the reproduction steps, you should be able to reproduce the bug, or if it is uncommon, occasionally reproduce the bug. smile


How NOT to write a bug:
Example1:

Computer Specs:
Windows

Location:
Slots


Location:
I don't remember

Bug:
The slots machine didn't work.

Reproduction:
Play slots by putting in tokens.

Result:
The slots machine didn't work.

Notice how everything is vague? If you were to try to go through the steps again, you would not have a clue where to start. Try to be as detailed as you can by giving any information such as: computer information and what you were doing before, if you used any power ups, etc. This way we can narrow down the possibilities.
Meromictic's avatar

Winged Stargazer

20,500 Points
  • Winged 100
  • Alchemy Level 10 100
Browser: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.22) Gecko/20110902 Firefox/3.6.22
Operation system: Microsoft Windows 7 Home Premium
Version 6.1.7600 Build 7600


Step 1- Log onto www.gaiaonline.com

Step 2- Go to alerts

Step 3- Go to add a phone number

Step 4- Type in cell number

Step 5- Hit next

Step 6- Wait for conformation code

Suppose to Result: Code is sent to cell phone for number to be added.


Act result: The conformation code is not being sent. I've tried a couple of times and waited several hours and nothing has happened.

If it helps I use Sprint
Phone Info:
Samsung Epic 4G Android
Android 2.1Platform Éclair

Sometimes you need to wait to get the code, but we always had issues with Sprint.
Woodlyn Fairee's avatar

Precious Kitten

9,550 Points
  • Cat Fancier 100
  • Object of Affection 150
  • V-Day 2011 Event 100
IDK if Im doing this properly but the cash tree icon is not working atm for me even though on my preferences page I have it checked off to be on.
~Lyn~
Computer Specs:
Windows XP
Chrome/14.0.835.186
Win 10, 3,183,10

Location:
Forums: Quick Reply/Reply Box

Bug:
"Drunk-Lookin" captcha appears in quick reply and will not go away. Captcha does not appear in Reply Box.

Reproduction:

1) Go to www.gaiaonline.com/
2) Go to http://www.gaiaonline.com/forum/
3) Click any forum or subforum
4) Click on "Quick Reply" or "Reply Box"
5) Captcha appears
6) Fill out words correctly
7) Click submit/reply

Suppose to result: Post is submitted; redirects you to new post

Act result: The captcha remains and will not submit my post.
I have experienced the same as Tsunsu but I'm here for an item that needs fixing.
Sorry, I won't bother filling out the appropriate form as none of that information is relevant.
This item:http://www.gaiaonline.com/marketplace/itemdetail/64567
Momotaro no Uta is an unfinished item.
Equip the item with nothing else on and turn around. The back view is not only my naked bum but the right hand sleeve is attached to my head instead of my arm. The nudity made me blush.
Sammy_Sue222's avatar

Benevolent Friend

9,050 Points
  • Forum Sophomore 300
  • Money Never Sleeps 200
  • Signature Look 250
gaia_angelleft Computer Specs:xx gaia_angelright
Windows 7 Home Edition
Mozilla Firefox 6.0.2

gaia_angelleft Location:xx gaia_angelright
Reply box to any thread.

gaia_angelleft Bug:xx gaia_angelright
Claiming I am trying to submit from the same form twice,
when I have done the following several times before.

gaia_angelleft Reproduction:xx gaia_angelright
1) Go to www.gaiaonline.com .
2) Log in.
3) Go to a thread; either a glowing tank thread or a bump thread
to not anger anyone with needless bumps.
4) Click to reply.
5) Fill in your post and all the coding you wish.
6) Click the Submit button.
7) When the "Your Post has been submitted," page loads, press to go back,
taking you to the reply box again.
9) Click the Submit button again to re-post what your previous
post, A.K.A., bumping.
10) Witness this show above the Reply box: [ x ]

User Image
***The text in the above image was only cropped and then the font color changed to red.***

gaia_angelleft Result:xx gaia_angelright
Your post will not go through and you will have to go back
through the thread in order to post.

gaia_angelleft Notes:xx gaia_angelright
I have done this numerous times before with no issues. It is useful
when bumping your own/another glow/bump thread.
This "glitch" is also occurring with the "Auto-bumps." The only difference
I have found between normal posting and the auto-bump posting is that
for the auto-bump to go through -after it loads the same message- you can hit Submit
and it will go through. ~It takes away from the point of an auto-bump.~
Whereas, if you click Submit after the message from the above steps, you
will find the page will just continuously load saying the same thing.
I realize that this could actually be a "fix" on Gaia's
part, but I'm posting here in hopes of being told so, or having this
corrected. 3nodding
Sammy_Sue222
gaia_angelleft Computer Specs:xx gaia_angelright
Windows 7 Home Edition
Mozilla Firefox 6.0.2

gaia_angelleft Location:xx gaia_angelright
Reply box to any thread.

gaia_angelleft Bug:xx gaia_angelright
Claiming I am trying to submit from the same form twice,
when I have done the following several times before.

gaia_angelleft Reproduction:xx gaia_angelright
1) Go to www.gaiaonline.com .
2) Log in.
3) Go to a thread; either a glowing tank thread or a bump thread
to not anger anyone with needless bumps.
4) Click to reply.
5) Fill in your post and all the coding you wish.
6) Click the Submit button.
7) When the "Your Post has been submitted," page, press to go back,
taking you to the reply box again.
9) Click the Submit button again to re-post what your previous
post, A.K.A., bumping.
10) Witness this show above the Reply box: [ x ]

User Image
***The text in the above image was only cropped and then the font color changed to red.***

gaia_angelleft Result:xx gaia_angelright
Your post will not go through and you will have to go back
through the thread in order to post.

gaia_angelleft Notes:xx gaia_angelright
I have done this numerous times before with no issues. It is useful
when bumping your own/another glow/bump thread.
This "glitch" is also occurring with the "Auto-bumps." The only difference
I have found between normal posting and the auto-bump posting is that
for the auto-bump to go through -after it loads the same message- you can hit Submit
and it will go through. ~It takes away from the point of an auto-bump.~
Whereas, if you click Submit after the message from the above steps, you
will find the page will just continuously load saying the same thing.


i have this same problem too!
beckygrendel's avatar

Aged Nerd

Aaaack! redface redface I figured it out. I did buy something - 2 of those clothing slots while working on a new avi. False alarm! whee redface
AzuAzu-Ha-ChaCha's avatar

10,050 Points
  • Heckler 50
  • Hunter 50
  • Consumer 100
Browser: IE9 & Google Chrome 14.0.835.186
Operation system: Windows 7 - home


Step 1- Log onto www.gaiaonline.com

Step 2- Go to inventory

Step 3- Click "Special" tabs

Step 4- Wait for it to load


Suppose to Result: Items classified "Special" are the only ones that appear in the tab.


Act result: Equip items (only SOME of them) appear, none of them classified as "special".
Mocha_Aulait's avatar

9,350 Points
  • Grunny Grabber 50
  • Grunny Rainbow 100
  • Grunny Harvester 150
Computer Specs:
Mozilla/5.0 (Windows NT 6.1) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/13.0.782.220 Safari/535.1

Location:
Mail (Outbox)

Bug:
Mail is being sent, but is stuck in the Outbox.

Reproduction:
1) Go to www.gaiaonline.com/
2) Log in as a user: user name and password
3) Go to the web page http://www.gaiaonline.com/mygaia
4) Click on Mail
5) Draft message
6) Send message
7) Click on the Outbox button

*The messages are trapped in my Outbox. They have accumulated and are not being sent.*

Result:
My emails are not transmitting.
The Hudson Hawk's avatar

Blessed Carpenter

9,700 Points
  • Friendly 100
  • Guildmember 100
  • Rebuilder 100
Hello! Todays date is 09-28-2011
Approx time is 7:11 pm edt.
Problem is: The daily crane machine is not showing on my screen or giving me daily's atm.
System is Windows I.E.
Help me out if you can please. Thank you.
The Hudson Hawk.
carbonphyber's avatar

Codebreaking Sex Symbol

8,200 Points
  • Citizen 200
  • Person of Interest 200
  • The Perfect Setup 150
The Hudson Hawk
Hello! Todays date is 09-28-2011
Approx time is 7:11 pm edt.
Problem is: The daily crane machine is not showing on my screen or giving me daily's atm.
System is Windows I.E.
Help me out if you can please. Thank you.
The Hudson Hawk.
Could you please check your Account Prefs and make sure Daily Chance is checked?
The Hudson Hawk's avatar

Blessed Carpenter

9,700 Points
  • Friendly 100
  • Guildmember 100
  • Rebuilder 100
carbonphyber
The Hudson Hawk
Hello! Todays date is 09-28-2011
Approx time is 7:11 pm edt.
Problem is: The daily crane machine is not showing on my screen or giving me daily's atm.
System is Windows I.E.
Help me out if you can please. Thank you.
The Hudson Hawk.
Could you please check your Account Prefs and make sure Daily Chance is checked?


Checked it and it was checked to happen. IDK why it didnt when I logged on. But its now working and problem is solved. Thank you!! smile
The Hawk
UnwantedSurrender's avatar

Beloved Lunatic

11,050 Points
  • Generous 100
  • Befriended 100
  • Friendly 100
Computer Specs:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0) Gecko/20100101 Firefox/5.0

Location:
Customize Avatar Page

Bug:
None of the buttons (other than the items) work.

Reproduction:
1) Go to www.gaiaonline.com/
2) Log in as a user: user name and password
3) Click my avi to go to "customize avatar" page
4) Click "get nekkid" button
5) Does nothing/clothes remain on
6) Go through every tab and take off all clothing
7) Go through and dress up avi once again
9) Hit "Save"
10) Nothing happens/just sits there
11) Try all the other buttons around picture of avi
12) None of them work

Result:
None of the buttons surrounding my avi's picture in the "Customize Avatar" work.

Notes:
It's been like this for, as far as I know, over a week now. Someone suggested clearing cache, deleting cookies, and restarting but it didn't work.

Quick Reply

Submit
Manage Your Items
Other Stuff
Get Items
Get Gaia Cash
Where Everyone Hangs Out
Other Community Areas
Virtual Spaces
Fun Stuff
Gaia's Games