Welcome to Gaia! ::

How to report a Bug

First thing to do when a member contact you regarding a possible bug:

1. Check an announcement!
If user experience a problem during some new project push it is probably
temporary and will be resolved after push is completed.

2. Can you reproduce the problem?

To make sure the problem is real:
Clean up the cash and cookie
Log out and log in back
Is it still reproducible?
If it is reproducible, please provide the following information:

OS: Mac? Win? WinXP?
Browser: IE6? IE7? FF? Safari? Opera?
Version: FF 2.0.5? FF 3? IE7 sp 2?
Brief description of the problem
steps to reproduce:

Example and templates are below.

3. Before you report the bug, please check other people's reports!!!!

4. Please report 1 bug in 1 post

REPORTING A BUG

Provide detailed and useful information when reporting!
The purpose of reporting a bug is so that later on a Developer will have enough information to reproduce the problem and resolve it. Reports made that do not provide useful information and are vague with no detail will be deleted.

Be descriptive in your title
Don't just put "Bug" in your title. For example, if something like Cinemas isn't poping up, put "Gaia Cinemas isn't popping up Bug."

Quick Format for posting bug reports:

Short description of the problem:


Browser:
Operation system:


Step 1- Log onto www.gaiaonline.com

Step 2-

Step 3-

Step 4-

Step 5-

Suppose to Result:


Act result:



Here's an example of how to write a bug:


Computer Specs:
Windows Vista Home Edition
Internet Explorer 7.0.6000.16609
Flash 9.0.115.0

Location:
Slots (Upper right hand corner of game)

Bug:
Playing winnings button does not work when you have over 10 winnings awarded

Reproduction:
1) Go to www.gaiaonline.com/
2) Log in as a user: user name and password
3) Go to the web page www.gaiaonline.com/games
4) Click on Slots
5) Pick any available room
6) Click on the Join button
7) Click on the Play Token button
cool Click on the Spin button
9) Repeat steps 7-8 until you have at least 10 winnings awarded

*Current winnings will display the number 10, right below Tickets and Tokens on the left center side

10) Click on the Play Winnings button

Result:
The button will not work. The current winnings do not decrement (decrease). The spin button does not work since no winnings or tokens are used.

Notes:
Any useful information goes here, such as how often this occurred.

If you notice for the above bug, it is very detailed and concise. If you were to go through the reproduction steps, you should be able to reproduce the bug, or if it is uncommon, occasionally reproduce the bug. smile


How NOT to write a bug:
Example1:

Computer Specs:
Windows

Location:
Slots


Location:
I don't remember

Bug:
The slots machine didn't work.

Reproduction:
Play slots by putting in tokens.

Result:
The slots machine didn't work.

Notice how everything is vague? If you were to try to go through the steps again, you would not have a clue where to start. Try to be as detailed as you can by giving any information such as: computer information and what you were doing before, if you used any power ups, etc. This way we can narrow down the possibilities.
Browser: Firefox 10. something
Operation system: Windows Vista


Step 1- Log onto www.gaiaonline.com

Step 2- Go to towns

Step 3- Collect various items on 5 or 6 different servers

Step 4- Exit towns via the 'x' at the top of the window

Step 5- check main inventory

Suppose to Result: Items collected in Towns should 'auto save' to my inventory every time I leave a server.

Act result: I have not been able to save a single thing. I understand that hitting the save button is now useless, but the new system isn't working.

Notes: I have refreshed my inventory, I have closed the browser, I have restarted my laptop, I have tried to do this on my desktop also, which runs AOL 9.0 because it is a POS. The problem is not on my end.

I'm not the only one having this problem. Here are other people.
http://www.gaiaonline.com/forum/bug-report-technical-support/trash-and-bugs-from-town-still-not-saveing/t.78282193/
http://www.gaiaonline.com/forum/bug-report-technical-support/items-in-town-not-saving/t.78295153/
http://www.gaiaonline.com/forum/bug-report-technical-support/towns-inventory-not-switching-over-to-main-inventory/t.78318141/
pd2care's avatar

12,650 Points
  • Autobiographer 200
  • Citizen 200
  • Hygienic 200
Computer Specs:
Windows Vista Profession Edition
Google Chrome (up to date according to "About" wink
Flash 9.0.115.0

Location:
Aquarium

Bug:
Certain fish go back to Barrett's tank still

Reproduction:
1) Go to www.gaiaonline.com/
2) Log in as a user: user name and password
3) Go to the web page www.gaiaonline.com/aquarium
4) click on Barrett's tank
5) Remove fish in there to main tank
6) Save Tank Status
7) Feed fish, click overseer
9) Save again
9) leave tank



Result:
This fish that were previously removed will be back in Barrett's tank. Have emptied cache and left Gaia completely, came back the next day with the same result of same fish back in Barrett's tank.
Dev report stated this was fixed. For me, it is not. The same 8 fish keep ending up back in Barrett's tank after I leave the page.
E n t a n g l e d L i e s's avatar

Shameless Nerd

OS: WinXP
Browser: I've tried Firefox and Chrome, both are updated.
Flash 11,2,202,183

Location: Towns
Bug: I receive the "cuss word" balloon every time I try to pick up a flower or piece of trash; however, as of one hour ago, I have been able to pick up bugs all of a sudden, but still no flowers/trash.

Reproduction:
1) Go to www.gaiaonline.com/
2) Log in as a user: user name and password
3) Go to the web page www.gaiaonline.com/launch/towns/
4) Go to any zip code either using the directory or simply clicking one of the arrows to switch sections
5) Click on any piece of trash/flower

Suppose to Result:
Items collected in Towns should be able to be picked up.

Act result:
I receive the "cuss button" every time I try to pick up a piece of trash/flower.

Notes: Other people are receiving this problem as well.
http://www.gaiaonline.com/forum/games-bugs/towns-flood-control-problem/t.78326855/?_gaia_t_=3936
http://www.gaiaonline.com/forum/bug-report-technical-support/picking-up-trash-misses-all-everything/t.78304583_1/
emmaaaa1234's avatar

900 Points
  • Gaian 50
  • Member 100
  • Dressed Up 200
i cant get into the gaia town.
CURRENT PROFILE BUG - repeating "wishlist" and "recent visitors" tabs, cannot delete them.

Location: Profile Prefs and My profile/edit my profile

Bug with current profile: my "wishlist" and "recent visitors" tabs are pretty much infinite, i can't delete them and there seems to be something blocking a big portion of my profile, like a big invisible wall.

1. I can't seem to find anyone else with this bug.

2. Can you reproduce the problem?
i have logged out and back in, cleared cookies, etc. still the same.

OS: Mozilla Firefox Beta


steps to reproduce:
i'm not sure exactly how i did this,
1. deleted all my tabs so i could make a minimalistic profile
2. kept only recent visitors and wish list up
3. added text with a link to leave me a comment, and a picture
4. hit "save"
5. wishlist and recent visitors tabs are repeating and i can't delete them.

I haven't seen this bug in any other people's posts, i just really want help!

Are you trying to delete wishlist and recent visitors panel from profile?? Could you please send screenshot.

Thanks
selvinivi
LollyxBeans's avatar

Rainbow Roisterer

10,450 Points
  • Popular Thread 100
  • Elocutionist 200
  • Mark Twain 100
Short description of the problem:

When topics are moved from one subforum to another within a guild, they disappear as if they are deleted; however, they aren't actually removed from the guild, they just...don't appear in any subforum. Reproducible.


Browser: Google Chrome.
Operation system: Windows 7


Step 1- Log onto www.gaiaonline.com

Step 2- Go to guilds

Step 3- Select thread to be moved. Move to desired subforum

Step 4- Click 'Return to forum'. Navigate to chosen subforum.

Suppose to Result: The moved thread should appear within the subforum.


Act result: Thread is not there. At all.
I'm having trouble w. my profile. Every time I try to delete a custom I save & it goes to " Error Database . Cannot Delete Customs" . It's been going on since tuesday.
Aynagirl's avatar

Gracious Gaian

Computer Specs:
Windows XP
Browser: AOL, Internet Explorer 7
Flash 9.0.115.0

Location:
Dress-Up

Bug:
Avi's right hand will not go into the down position.

Reproduction:
1) Go to www.gaiaonline.com/
2) Log in as a user: user name and password
3) Go My Gaia
4) Click on Avatar
5) Click on Get Nekkid
5) Click on Choose Pose
6) Pick Hand position {aa} both down


Result:
The avi's right hand will not go into the down position. I started having trouble with it last weekend. It would have to be clicked on twice or reset a few times to get the hand in the down position, but it would work. I noticed this week that her hand was in the hold position and I haven't been able to put it in the down position at all now.

Notes:
This has only been happening since Friday, March 2, 2012. Thank you.
Eriu-hime's avatar

Liberal Nerd

8,000 Points
  • Citizen 200
  • Conventioneer 300
  • Generous 100
I bought a luck key with Gaia Cash. it was taken out of my total cash ammount. but when I try to open a treasure box, I am told to go buy a key from phin phang (which doesn't even sell them, I get luck keys from the cash shop)- what gives? The key is not in my inventory either!
InsomniaWolf's avatar

Greedy Werewolf

5,400 Points
  • Team Jacob 100
  • Grunny Rainbow 100
  • Citizen 200
OS: Windows 7
Browser: Google Chrome
Flash: 11.1.102.55

Location: Rally
Bug: Every time I go to get on rally I can sometimes chat for a few minutes then it disconnects me from the server and after a few seconds this pops up
Note: Town Server
Code: Joining Server Failed
System Message: Try reloading Gaia Towns. Report this if it fails the second time.

Reproduction:
1) Go to www.gaiaonline.com/
2) Log in as a user: user name and password
3) Go to the web page www.gaiaonline.com/launch/rally/
4) Go into any rally room
5) Chat or try and place your car in a spot

Result: After a few seconds of chatting all the buttons stop working and the chat system disconnects from server.

Quick Reply

Submit
Manage Your Items
Other Stuff
Get Items
Get Gaia Cash
Where Everyone Hangs Out
Other Community Areas
Virtual Spaces
Fun Stuff
Gaia's Games