Welcome to Gaia! ::

How to report a Bug

First thing to do when a member contact you regarding a possible bug:

1. Check an announcement!
If user experience a problem during some new project push it is probably
temporary and will be resolved after push is completed.

2. Can you reproduce the problem?

To make sure the problem is real:
Clean up the cash and cookie
Log out and log in back
Is it still reproducible?
If it is reproducible, please provide the following information:

OS: Mac? Win? WinXP?
Browser: IE6? IE7? FF? Safari? Opera?
Version: FF 2.0.5? FF 3? IE7 sp 2?
Brief description of the problem
steps to reproduce:

Example and templates are below.

3. Before you report the bug, please check other people's reports!!!!

4. Please report 1 bug in 1 post

REPORTING A BUG

Provide detailed and useful information when reporting!
The purpose of reporting a bug is so that later on a Developer will have enough information to reproduce the problem and resolve it. Reports made that do not provide useful information and are vague with no detail will be deleted.

Be descriptive in your title
Don't just put "Bug" in your title. For example, if something like Cinemas isn't poping up, put "Gaia Cinemas isn't popping up Bug."

Quick Format for posting bug reports:

Short description of the problem:


Browser:
Operation system:


Step 1- Log onto www.gaiaonline.com

Step 2-

Step 3-

Step 4-

Step 5-

Suppose to Result:


Act result:



Here's an example of how to write a bug:


Computer Specs:
Windows Vista Home Edition
Internet Explorer 7.0.6000.16609
Flash 9.0.115.0

Location:
Slots (Upper right hand corner of game)

Bug:
Playing winnings button does not work when you have over 10 winnings awarded

Reproduction:
1) Go to www.gaiaonline.com/
2) Log in as a user: user name and password
3) Go to the web page www.gaiaonline.com/games
4) Click on Slots
5) Pick any available room
6) Click on the Join button
7) Click on the Play Token button
cool Click on the Spin button
9) Repeat steps 7-8 until you have at least 10 winnings awarded

*Current winnings will display the number 10, right below Tickets and Tokens on the left center side

10) Click on the Play Winnings button

Result:
The button will not work. The current winnings do not decrement (decrease). The spin button does not work since no winnings or tokens are used.

Notes:
Any useful information goes here, such as how often this occurred.

If you notice for the above bug, it is very detailed and concise. If you were to go through the reproduction steps, you should be able to reproduce the bug, or if it is uncommon, occasionally reproduce the bug. smile


How NOT to write a bug:
Example1:

Computer Specs:
Windows

Location:
Slots


Location:
I don't remember

Bug:
The slots machine didn't work.

Reproduction:
Play slots by putting in tokens.

Result:
The slots machine didn't work.

Notice how everything is vague? If you were to try to go through the steps again, you would not have a clue where to start. Try to be as detailed as you can by giving any information such as: computer information and what you were doing before, if you used any power ups, etc. This way we can narrow down the possibilities.
Armours's avatar

Original Genius

12,500 Points
  • Nerd 50
  • Survivor 150
  • Grunny Rainbow 100
Computer Specs:
Microsoft Windows XP
Google Chrome 16.0.912.77

Location:
Gaia Clans Page

Bug:
I can't join any clans, it says that I belong to more than one clan, but I currently don't belong to any clans

Reproduction:
1) Go to GaiaOnline.com

2) Log in as a User: Put in my user name and password

3) Get to the Gaia Home section

4) Hover on Forums, and then click Clans

4) Click on Find A Clan button

5) Click any Clan and then click the '+ Join' button

6) Then the error page shows up: General Error User belongs to more than one clan

*But I currently don't belong to any clans

Result:
The error page keeps popping up, no matter what I do

Notes:
This had happens for a long time now, I've waited for a month, clear my browsing data, etc. and then I tried joining again, but the same error pops up and it's getting to the point where it's annoying me because I really enjoy playing zOMG and I just want to join a clan.

I had searched on Google to see if there were any results, but there weren't any, so I decided to report this and see if there are any results

User Image - Blocked by "Display Image" Settings. Click to show.

Hi, Could please send a PM to our developer (carbonphyber) regarding your issue.

Thanks
selvinvi
Memette's avatar

5,700 Points
  • Dressed Up 200
  • Forum Dabbler 200
  • Treasure Hunter 100
Computer Specs
Dell Inspiron
Windows 7 Home Edition
Browser Informatation:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0


Location: My Gaia

Steps

- Log in Username and Password
- Go to My Gaia
- Click Avatar
- Click on Random items to equip character in the dressing room
- Click save, reset, get nekkid, change lips... none of it worked.

Problems:
Memette
Darien S.
What's actually happening when you try?


When I click the buttons to change the facial expressions, the drop down menu that's supposed to show up for you to select the lips you want doesn't come up. The menu is frozen and it just stays the same as if I hadn't clicked it. The same thing happens when I try to press the save button. No matter how many times I click it, it won't go to the next screen and process the changes I've made. In fact, everything on the left hand corner doesn't work. Whether I want to reset, get "nekkid", sit down or stand up, face front or back--- every tab on the left hand corner stays frozen as if I never clicked them at all.

NOTE: I can put items on my avatar by clicking clothing on items in the left hand corner of the dressing room in "My Gaia". I just can't save the changes or use anything on the left.



2)The avatar will not try on preview cash shop items if I'm in "My Gaia". While it DOES show me a drop down of the different poses and items a particular preview item has when I click it, it won't actually equip it onto the avatar.

I'd post the source code but I'm limited to 50,000 characters.

Hi, Could please reset your avatar and try now if you could save it.

Thanks
selvinivi


Hi, Below is the messsage from our devs:


"This user says the can't click on the image buttons.

This is probably due to something they have installed in their browser. Some third party add-ons have been
known to cause problems. It could also be that their Firefox settings might be blocking something.
It's hard to say, but I also have Firefox 10 and don't have any problems with the avatar page."


Thanks
selvinivi
mixtures's avatar

Sophomore

Computer Specs
IBM Thinkpad (computer type) (laptop)
Windows XP
Browser Informatation: Google chrome
this was on the bottom of the submit, I've never done this before so I put it here: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.77 Safari/535.7

Location: My Gaia, avatar.

Steps

- Log in Username and Password
- Go to My Gaia
- Click Avatar
- Click on Random items to equip character in the dressing room
- Click reset, get nekkid, any item
- click save
- a window pops up, it says "save failed please try again. Reason: Unable to move items in during the avatar save. Please try again. serial_not_in_owner_location. If the problem persists, please click on 'get nekkid' , save avatar, and try again."

Problems: when I try to save my avatar, it pops up a window that says: "save failed please try again. Reason: Unable to move items in during the avatar save. Please try again. serial_not_in_owner_location. If the problem persists, please click on 'get nekkid' , save avatar, and try again." I tried the get nekkid thing, it doesn't work. I try to save again. Then I go on another gaia page, and it does look like it saved, but it says it didn't when I go back to the avatar page. Some items went missing, and some duplicated. I put a list of items duplicated and missing just in case:

MISSING

Cutie animalie
simple orange skirt
there are more possibly

DUPLICATED

Dashing gentlemen classic dress shirt
Red rakish vest
Detective kit
Blue ribbon skirt
Bretelles demonique
Gold heart hairpin
Egyptian gold anklet x2
nuetral glitzy starter headband
possibly more...

Hi, Could you please try to save your avatar now, reset your avatar first.

Thanks
selvinivi
Computer Specs:
Windows 7
Internet Explorer 7.0.6000.16609
Mozilla/5.0 (Windows NT 6.1; rv:10.0) Gecko/20100101 Firefox/10.0
Flash 9.0.115.0

Location:
Inventory

Bug:
Gift does not open

Reproduction:
1) Go to www.gaiaonline.com/
2) Log in as a user: user name and password
3) Go to the web page www.gaiaonline.com/mystuff
4) Click on the white and blue gift box in the 'special' tab
5) Choose 'open item'

Result:
Item does not open. The message 'General Error
Error opening gift box, please try again later' keeps coming up.

Notes:
This has been happening with the same item for months. I thought the issue might have been a site bug and would have been fixed by now but I guess it's just my inventory.


Hi, Our developers will be working on it, so try to open your gift box by tomorrow and see if it works. Please let me know if it doesn't work.

Thanks
selvinivi

Quick Reply

Submit
Manage Your Items
Other Stuff
Get GCash
Offers
Get Items
More Items
Where Everyone Hangs Out
Other Community Areas
Virtual Spaces
Fun Stuff
Gaia's Games