Welcome to Gaia! ::

jseverin's avatar

3,550 Points
  • Conventioneer 300
  • Beta Gaian 0
  • Beta Voter 0
How to report a Bug

First thing to do when a member contact you regarding a possible bug:

1. Check an announcement!
If user experience a problem during some new project push it is probably
temporary and will be resolved after push is completed.

2. Can you reproduce the problem?

To make sure the problem is real:
Clean up the cash and cookie
Log out and log in back
Is it still reproducible?
If it is reproducible, please provide the following information:

OS: Mac? Win? WinXP?
Browser: IE6? IE7? FF? Safari? Opera?
Version: FF 2.0.5? FF 3? IE7 sp 2?
Brief description of the problem
steps to reproduce:

Example and templates are below.

3. Before you report the bug, please check other people's reports!!!!

4. Please report 1 bug in 1 post

REPORTING A BUG

Provide detailed and useful information when reporting!
The purpose of reporting a bug is so that later on a Developer will have enough information to reproduce the problem and resolve it. Reports made that do not provide useful information and are vague with no detail will be deleted.

Be descriptive in your title
Don't just put "Bug" in your title. For example, if something like Cinemas isn't poping up, put "Gaia Cinemas isn't popping up Bug."

Quick Format for posting bug reports:

Short description of the problem:


Browser:
Operation system:


Step 1- Log onto www.gaiaonline.com

Step 2-

Step 3-

Step 4-

Step 5-

Suppose to Result:


Act result:



Here's an example of how to write a bug:


Computer Specs:
Windows Vista Home Edition
Internet Explorer 7.0.6000.16609
Flash 9.0.115.0

Location:
Slots (Upper right hand corner of game)

Bug:
Playing winnings button does not work when you have over 10 winnings awarded

Reproduction:
1) Go to www.gaiaonline.com/
2) Log in as a user: user name and password
3) Go to the web page www.gaiaonline.com/games
4) Click on Slots
5) Pick any available room
6) Click on the Join button
7) Click on the Play Token button
cool Click on the Spin button
9) Repeat steps 7-8 until you have at least 10 winnings awarded

*Current winnings will display the number 10, right below Tickets and Tokens on the left center side

10) Click on the Play Winnings button

Result:
The button will not work. The current winnings do not decrement (decrease). The spin button does not work since no winnings or tokens are used.

Notes:
Any useful information goes here, such as how often this occurred.

If you notice for the above bug, it is very detailed and concise. If you were to go through the reproduction steps, you should be able to reproduce the bug, or if it is uncommon, occasionally reproduce the bug. smile


How NOT to write a bug:
Example1:

Computer Specs:
Windows

Location:
Slots


Location:
I don't remember

Bug:
The slots machine didn't work.

Reproduction:
Play slots by putting in tokens.

Result:
The slots machine didn't work.

Notice how everything is vague? If you were to try to go through the steps again, you would not have a clue where to start. Try to be as detailed as you can by giving any information such as: computer information and what you were doing before, if you used any power ups, etc. This way we can narrow down the possibilities.
lillymon12's avatar

9,700 Points
  • Bunny Hoarder 150
  • Signature Look 250
  • Citizen 200
Computer Specs:
Windows XP

Browser:
I have both Mozilla Firefox 9.0 and Internet Explorer 8. I have gotten the same results from both.

Location:
World Map

Bug:
Santa is not showing up on my world map. The shops send me to the world map to collect my caroling item but Santa is no where on the world map.

Reproduction:
1) Go to www.gaiaonline.com/
2) Log in as a user: user name and password
3) Go to the web page http://www.gaiaonline.com/market/
4) Enter shop (not cash shop though)
5) Click the world map link in shop owners speech bubble
6) Search each area of world map

Result:
Santa does not show up on any of the world map areas.

Notes:
This started happening Tuesday Dec 20 sometime between 10:30pm and 11:00pm, I'm not sure of the exact time. I have tried logging out, clearing my cache and cookies then closing my browser, opening my browser back up, and repeating the steps I listed but received the same results. I even restarted my computer and repeated everything but got the same results still. I searched for Santa on the world map the night of Dec 20 two times then logged out and logged back in and searched another two times, I then logged out for the night and logged back in the morning of Dec 21 and searched another two times.
There is a terrible occasional freeze in rally and it just stops working and i really want it to get fixed so could you help me out a little bit?
frosting_heart's avatar

5,750 Points
  • Person of Interest 200
  • Flatterer 200
  • Peoplewatcher 100
the Blood Droplet 's i'm getting in ZOMg, aren't showing up in my inventory.
Demon_soulex's avatar

5,950 Points
  • Window Shopper 100
  • Money Never Sleeps 200
  • Signature Look 250
I can't donate anything on the christmas event. sad
keyvaskull's avatar

Dangerous Voter

9,300 Points
  • Trick or Treat 100
  • Millionaire 200
  • Luck of the Draw 50
I have windows 7, internet explorer 9, flash 10.0
Bug location: Inventory
Issue: I donated several items then I was granted a candy cane item. I checked my inventory for the item and it doesn't show up anywhere unless I do the inventory search or click the all tab in my inventory. (If this is even a bug or you just haven't decided where it belongs yet smile

(Also I know this is repeating but I was never given my2k11 halloween healer badge even though I wrote a bug report on it. Will I ever receive it?) neutral
lamoxlamae's avatar

Beloved Phantom

Browser: Mozilla/5.0 (Windows NT 5.1; rv:5.0.1) Gecko/20100101 Firefox/5.0.
Operation system: Windows XP with Service Pack 3


Step 1- Log onto www.gaiaonline.com

Step 2- Buy Honorable Shoji Black Lamp (or have it in inventory already)

Step 3- Select to see it in your house

Step 4- Try to put Honorable Shoji Black Lamp in house.

Suppose to Result: An Honorable Shoji Black Lamp should appear in the house

Act result: An Honorable Shoji Wooden Lamp appears instead.

I checked my inventory and house to make sure that I do not own the wooden version. I own two of the black ones. I even bought the second brand new from the store to be certain that I had not made a mistake! I tried rotating, removing and re-adding the item, and refreshing my browser but it still was wooden instead of black.
inky_T.A.E.'s avatar

8,000 Points
  • Conventioneer 300
  • The Perfect Setup 150
  • Money Never Sleeps 200
Demon_soulex
I can't donate anything on the christmas event. sad


Same here.
Short description of the problem:Can not donate in x-mas event.


Browser:Internet Explorer
Operation system:Windows


Step 1- Log onto www.gaiaonline.com

Step 2-Go to X-mas event page.

Step 3-I click the donate button on the event page and my inventory comes up, but it won't let me change the page I'm on even though there are twelve and when I click an arrow, or an item, or the donate button after typing in a gold amount, the page just goes away instead of taking me to the confirmation step.

Suppose to Result:Click to donate then go to confirmation and then donation goes through. Click on arrow change inventory page.


Act result:The page just goes away instead of taking me to the confirmation step or changing inventory page.
Song_of_fire's avatar

Destitute Hoarder

Computer Specs:
Windows 7 Home Premium
Google Chrome 16.0.912.63 m

Location:
Christmas Event (item and gold donation)

Bug:
Frame does not display right hand side. Cuts off both the right hand arrow as well as confirmation and cancel buttons.

Reproduction:
1) Go to www.gaiaonline.com/
2) Log in as a user: user name and password
3) Go to the web page http://www.gaiaonline.com/event/xmas2011/
4) Click on 'Donate'
5) Attempt to donate an item or scroll right.

Result:
Right arrow not visible, nor are the OK or Cancel.

Notes:
Screen shots of problem
Right arrow not visible [screen shot]
OK and Cancel buttons not visible [screen shot]

Error only occurs in Chrome, not in Sleipnir. (A Browser which uses the Internet Explorer engine.)
Fennir Rai Soleil's avatar

4,500 Points
  • Befriended 100
  • Signature Look 250
  • Hygienic 200
Ysterday I spent over 4 hours putting together my wishlist and perfecting everything. Everything was fine until I saved my changes. Now everything is gone! Please fix my wishlist crying


This is the kind of crap that makes me avoid Gaiaonline like the plague for months at a time x.x
AngeIsThanatos's avatar

Dangerous Animal

16,800 Points
  • Partygoer 500
  • Alchemy Level 10 100
  • Conventioneer 300
Computer Specs:
Mac OSX 10.5.8 Intel
Firefox 9.0.1

Location:
All landing pages

Bug:
Cannot collect Daily Chance, page remains greyed out until manually refreshed

Reproduction:
1) Go to www.gaiaonline.com
2) Click on Daily Chance cart on any of the landing pages (Home, My Gaia etc.)
3) Error message appears: "Oops! There was an error retrieving your reward: The daily reward was already claimed for today." (see screenshot)
4) Click on link to close the text box.
5) Page remains greyed out and no other items can be clicked on.


Result:
Daily Chance reward is not granted and the page must be refreshed in order to proceed.

Notes:
User Image

I have cleared the cache and deleted all Flash storage files since updating Firefox; same result. I've also tested this on both my mule accounts and the same thing happens.
Kurai Hexious's avatar

7,000 Points
  • Wall Street 200
  • Invisibility 100
  • Forum Sophomore 300
Computer Specs:
G62 HP w/ Windows 7
Firefox 9.0.1

Location:
All landing pages

Bug:
Every time I try to claim my daily reward it says:

"Oops!

There was an error retrieving your reward:

The daily reward was already claimed for today."


Even though I have not claimed it. It has been happening for about two weeks now. I thought it was a temporary glitch, but it has not gone away.

Reproduction:
1) Go to www.gaiaonline.com
2) Click on Daily Chance cart on any of the landing pages.
3) Error message appears: "Oops! There was an error retrieving your reward: The daily reward was already claimed for today."
4) Click on link to close the text box.
5) Page remains greyed out and no other items can be clicked on.


Anything I can do about this?
Report Bug: CAPTCHA Missing on quick post and post reply - Forum

Location: All Forums

- Issue: Happened to my other account (Drag0n_Child)
It happened previously, like last month but after a day, it was back to normal. Except now the issue has come back and it have been few days and today when i came back the captcha box still missing and i can't post in forum because of it.

1. Check an announcement & Other topics?
A: Yes i did and can't see any announcement about this issue. I saw a similar topic in this forum in regards to CAPTCHA missing in forum replies/post but it was few months ago and no one replied to that yet

2. Browser: Mozilla Firefox 9.0,1 & Internet Explorer 9.0.4

3. Operation system: Windows 7 Pro 64bit

4. Other Information:
I tried on both browser Mozilla and internet explorer, clear all cache, cookies and history. I even tried restarting my computer and the internet connection, i thought it was from my browser but i've check all the appliances and addons, it is all up to date including flash, adobe and java etc etc. I even tried to try use another computer but the result is the same.

The captcha picture/box has disappeared, i cannot post anywhere in the forum with that account, not even here. Thats why i'm using this one to report. But if i played Booty grabbed, the captcha box is there but not when i'm trying to post in the forum. Please help me crying

5.Reproduction:


Step 1- Log onto www.gaiaonline.com
Step 2- Go to Forum > ChatterBox
Step 3- Select a topic in that forum
Step 4- Click "reply" - Fill in > Sumbit
Step 5- Error: fill in captcha..
> Theres no Captcha box at all. So theres no way i can fill it in if it doesn't show up. sad

Result: Cannot Post at all...

6. Proof:
User Image - Blocked by "Display Image" Settings. Click to show.

Please help me with this issue...so i can post again :/
I am reporting a bug with my avatar. When i have grim reaper and decaying animals its causes a green barrier in the back ground of my avatar where my arms and legs should be for example look at my avatar and its self explanitory
Computer Species- Windows 7 Home Edition
Browser-Opera

Description of problem- Whenever i wanna edit my profile these pics i had for pretty much a while won't go away. Usually i would just click the "x" thing but this time they didn't go away, its like they're permanent. They really get in the way of my information and make my profile look ugly so can you guys please help me? very much appreciated ^_^

1) Log onto gaiaonline
2) Click my gaia
3)Click my profile
4)click edit my layout
5) try to erase pictures by clicking the "x" but won't go away

Reason why it's a bug is because they are suppose to disappear but they don't

Quick Reply

Submit
Manage Your Items
Other Stuff
Get GCash
Offers
Get Items
More Items
Where Everyone Hangs Out
Other Community Areas
Virtual Spaces
Fun Stuff
Gaia's Games