Welcome to Gaia! ::

Dolce Rogue's avatar

Diamond Senshi

Hello! I hope you can help me with this problem:

So, before the YouTube format changed I used to have the Play/Pause button on my profile, and this used to be my code:


.media_panel object, .media_panel embed{
width:30px;
height:25px;
}


But then, they changed it and it ******** up my video. When using this code, it only shows a very small square with the video in it, not the button. It's like the entire video shrugged to the size of the button.

Then I searched for the new code and found this:

#multimedia object, #multimedia embed
{ height: 25px; width: 30px; border: none; }

^This is supposed to go on my overdrive.

http://youtube.googleapis.com/v/(video ID)?version=2&autoplay=1

^This on my media panel.

But thing is, it doesn't work either. I saved my profile with this code and it won't even show the video, plain and simple. No button, no video, no nothing. Just an empty panel.

So, my question is: How do I fix this?

And in case I can fix it, could you please tell me how to make my media panel transparent and just show the button? I forgot how to do it sweatdrop

Thanks in advance!
Bornes's avatar

Aged Phantom

User ImageYoutube changed their layout of videos recently and I had the same problem.

I haven't actually tried it but I'm willing to bet if you go to the youtube video, click "embed", check the "Use old link" and then use the link that's given after the embed src= part you may have better luck.
Dolce Rogue's avatar

Diamond Senshi

Bornes
User ImageYoutube changed their layout of videos recently and I had the same problem.

I haven't actually tried it but I'm willing to bet if you go to the youtube video, click "embed", check the "Use old link" and then use the link that's given after the embed src= part you may have better luck.


...And how do I get there? xD
Bornes's avatar

Aged Phantom

Dolce Rogue


...And how do I get there? xD
User ImageGo to the video on youtube.com.
click 'embed' button under the video.
Check the "Use old code" button.

copy/paste heap of code into notepad.
Get the url after embed src=".
Dolce Rogue's avatar

Diamond Senshi

Bornes
Dolce Rogue


...And how do I get there? xD
User ImageGo to the video on youtube.com.
click 'embed' button under the video.
Check the "Use old code" button.

copy/paste heap of code into notepad.
Get the url after embed src=".


Ohhh okay, okay! Trying this!

Thanks Q!
Dolce Rogue's avatar

Diamond Senshi

Bornes



;n; Didn't work.
Bornes's avatar

Aged Phantom

User ImageThen I don't know. Sorry. =(
You can see I basically did the equivalent of "******** it" on my profile. I was tired of messing with it.
Horntastic's avatar

Dapper Phantom

Ok, a couple of things.
First off, your media is currently hidden and set to be quite large.
If you want it to display and be a play/pause button, first take that out:
.media_panel embed, .media_panel object{height: 400px; width: 480px;}.media_panel {position: absolute; left: -2000px; }.media_panel{background: transparent;}.media_panel h2{display: none;}

The first CSS you have in your post (the stuff with .media_panel) was the correct code to make it a play button, it's the Youtube URL that needs to be fixed.
The other CSS (the stuff with #multimedia) is the kind for the Classic-style profiles, not your Current-style profile.

Your media URL should be of the following format in order for the play button CSS to work now:

http://youtube.googleapis.com/v/111VxgGRZQQ&version=2&autoplay=1

The bolded portion is the video ID, the part after ?v= or /v/ in the normal URL. I took this one off your current profile.
This is fairly similar to what you have in your first post, so I'm not 100% sure what happened when you tried it, but I tested mine and it should work.

Youtube changed how their player behaves, most notably making the play bar collapse when unhovered and certain videos not playing when the player is too small, which doesn't have those issues. The version tag reverts it to the old style player. You should also be able to use the color tags if you like I think.

To make the panel transparent without completely hiding it, use:
.media_panel { background: transparent; }

And to remove the media panel header:
.media_panel h2 { display: none; }


[this post has been edited because apparently I cannot read]
Dolce Rogue's avatar

Diamond Senshi

Horntastic
Ok, a couple of things.
First off, your media is currently hidden and set to be quite large.
If you want it to display and be a play/pause button, first take that out:
.media_panel embed, .media_panel object{height: 400px; width: 480px;}.media_panel {position: absolute; left: -2000px; }.media_panel{background: transparent;}.media_panel h2{display: none;}

The first CSS you have in your post (the stuff with .media_panel) was the correct code to make it a play button, it's the Youtube URL that needs to be fixed.
The other CSS (the stuff with #multimedia) is the kind for the Classic-style profiles, not your Current-style profile.

Your media URL should be of the following format in order for the play button CSS to work now:

http://youtube.googleapis.com/v/111VxgGRZQQ&version=2&autoplay=1

The bolded portion is the video ID, the part after ?v= or /v/ in the normal URL. I took this one off your current profile.
This is fairly similar to what you have in your first post, so I'm not 100% sure what happened when you tried it, but I tested mine and it should work.

Youtube changed how their player behaves, most notably making the play bar collapse when unhovered and certain videos not playing when the player is too small, which doesn't have those issues. The version tag reverts it to the old style player. You should also be able to use the color tags if you like I think.

To make the panel transparent without completely hiding it, use:
.media_panel { background: transparent; }

And to remove the media panel header:
.media_panel h2 { display: none; }


[this post has been edited because apparently I cannot read]


Sorry for the late reply! Gaia didn't send me any notices. I'll try to do this as soon as I get on my computer.

EDIT: It worked! Thank you so much!


EDIT1: The button is there, but the song doesn't play ;n;

Quick Reply

Submit
Manage Your Items
Other Stuff
Get GCash
Offers
Get Items
More Items
Where Everyone Hangs Out
Other Community Areas
Virtual Spaces
Fun Stuff
Gaia's Games