Welcome to Gaia! ::

Okay so i'm not 100% if this is the right place to ask, if it's not i'm sorry please don't harass me out of existence. Anyway when I go to load up towns it gives me a message saying "please log into gaia" and a little button to do so. Even as I write this topic now it does this, and obviously I need to be logged in to do write the topic in the first place. With that being said I have tried updating my flash player, clearing my cache and such, oh and i've even clicked the button. I have logged in and back out and tried this on a mule account with the same result. Can someone please help? Or at least tell me if this has happened to them or anyone else they know? The main reason I get on is to go mess around in towns so any tips, advice, whatever is appreciated!
Ylaraniala's avatar

Shameless Genius

7,700 Points
  • Overstocked 200
  • Tycoon 200
  • The Perfect Setup 150
It is possible that your browser isn't the most optimum... if you aren't already, try using Firefox. I don't know if that will help, but it's the only thing I can think of.

Quick Reply

Submit
Manage Your Items
Other Stuff
Get GCash
Offers
Get Items
More Items
Where Everyone Hangs Out
Other Community Areas
Virtual Spaces
Fun Stuff
Gaia's Games